
Quick Start Guide  
TWR-S08PT60
5-Volt S08P Family of 8-bit MCUs for
Industrial and Appliance Applications

TOWER SYSTEM



Quick Start Guide

Get to Know the TWR-S08PT60

TWR-S08PT60 
Freescale Tower System
The TWR-S08PT60 module is a part of the Freescale Tower System, 
a modular development platform that enables rapid prototyping and 
tool re-use through reconfigurable hardware. Elevate your design to 
the next level and begin constructing your Tower System today.
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The TWR-S08PT60 Tower System module demonstrates the capability of 
the MC9S08PT60 8-bit MCU targeted for industrial and home appliance 
applications. It can function as a stand-alone, low-cost platform for the 
evaluation of MC9S08PT60 devices. There is an OSBDM module on the 
TWR-S08PT60 which can be used to debug MC9S08PT60 devices on 
both the TWR-S08PT60 module and external customer boards. 

The MC9S08PT60 is part of the 5-volt S08PT family of MCUs, offering 
exceptional EFT/ESD performance, more durability and reliability for 
harsh industrial and user interface environments and alignment with the 
IEC60730 appliance safety standard. The S08P family is pin compatible 
and integrates a touch-sensing interface (TSI), EEPROM and a motor 
control flex timer to simplify designs and help reduce system costs.

TWR-S08PT60 Features

MC9S08PT60 Features
•	 8-bit S08L core 
•	 Up to 20 MHz CPU at 2.7–5.5 V
•	 60 KB flash, 4 KB RAM, 256B EE
•	 12-bit ADC, 16-ch.
•	 Analog comparator
•	 16-ch. touch-sensing input

•	 Multiple timers, motor control,  
		 PWM capable

•	 Rich connectivity, including SCI,  
		 SPI and I2C

•	 57 GPIOs, including 8-pin, 20 mA  
		 drive and 2-pin true open-drain



•	 Go to the Help menu in the  
current window

•	 Select “Install New Software” item 
from the drop down menu

•	 	In the “Install” dialog, click the “Add” 
button in the upper right corner

•	 In the “Add Site” dialog, fill your 
favorite site name as the update 
location in the “Name” text box and 
click the “Archive” button

•	 In the “Repository archive” browse 
dialog, select the zip archive 
containing the Service Pack Updater 
Archive and click “Open”

•	 Open the “Work with:” drop down 
list and select the update location you 
have just added

•	 Select (check) the MCU Service 
Pack “MCU V10.1 Serivce Pack 
for MC9S08PT60” and uncheck 
“Contact all updates sites during 
install to find required software”  
item, then click “Next”
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Install Software  
and Tools

Please insert the provided DVD into your 
computer. After the initial screen appears, 
install CodeWarrior development tools 
in the order detailed below. Follow the 
prompts through the installation of each 
component, answering each prompt with 
the default input.

1. Install CodeWarrior Development Studio 
for Microcontrollers v10.1. Also install 
CodeWarrior MCU v10.1 Update 1.0.1 
(CW_MCU_V10.1_Update_1.0.1.zip) or 
newer by following the instructions in 
CodeWarrior_Service_Pack_Update_
Procedure.pdf found on the DVD. 

2. Install CodeWarrior Service Pack for 
MC9S08PT60 by following these steps:

•	 Open the CodeWarrior application 
from the Windows Start menu

•	 Select the required workspace  
and click “OK”

Step-by-Step Installation Instructions 
In this quick start guide, you will learn how to set up the TWR-S08PT60 module  
and run the lab code.
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Set up the  
TWR-S08PT60 Module

Remove the TWR-S08PT60 module from 
anti-static pouch. Ensure the jumpers 
are in the default positions as shown in 
the Default Jumper Options table on the 
following pages of this quick start guide. 

After ensuring the jumpers are in the 
default positions, connect provided USB 
cable from a free USB port on your 
computer to the mini-B USB connector on 
the TWR-S08PT60 module. Allow the  
PC to automatically configure the USB 
drivers as needed. USB drivers for your  
TWR-S08PT60 module were pre-loaded in 
the CodeWarrior installation.

•	Wait for the Updater to open the 
archive and the “Install/Install 
Details” dialog will appear. Select 
the Service Pack and click “Finish.” 
This will automatically install all the 
Service Pack dependencies

•	 Select the “I accept the terms of 
the license agreement” button and 
click “Finish”

•	 You will be asked to restart 
CodeWarrior again. Select “Yes”

3.	Install PEMICRO Embedded Multilink 
Toolkit (Terminal Window version 2.03 
or newer is required for labs).

4. Create a local workspace (folder) on 
your computer, for example, PT60Lab.

5. Install four CodeWarrior project files 
by selecting the Training tab and unzip 
these files to the local workspace that 
was just created on your computer.

TOWER SYSTEM
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Step-by-Step Installation Instructions (cont.)

Start CodeWarrior and 
Debug Environment

1. Start CodeWarrior by selecting it from 
the Windows Start menu.

2. From the CodeWarrior main menu, 
choose “File > Switch Workspace” 
and select “Other…” The Workspace 
Launcher dialog appears where the 
current (default) workspace name is 
displayed on “Workspace:” edit text 
box. If this workspace is not the one 
on your computer that contains lab 
projects, click “Browse…” to launch 
the “Select Workspace Directory” 
dialog. In this dialog, browse to the 
project folder (workspace) containing 
the lab projects and select it by clicking 
“OK.” The project folder appears on 
the “Workspace” text box. Click “OK” 
to allow CodeWarrior to configure and 
switch to the desired workspace.

3. Click “File > Import…” menu item 
to open Import dialog. In the Import 
dialog, double click “General” and 
select the “Existing Projects into 
Workspace” item followed by selecting 
“Next.” The Import Projects dialog 
appears.

4. In the “Select root directory” dialog, 
click “Browse…” Browse to and select 
the project folder “TWR-S08PT60_
Lab1_6” followed by clicking “OK.” 
The project name will appear in the 
Projects list and will be checked. Ensure 
“Copy projects into workspace” is 
unchecked, and click “Finish.”

5. When the Remote System Missing 
dialog appears, click “Yes” until the 
Welcome window appears. Close  
this window.

6.  Click the fast view icon at the 
bottom left of the window which 

will pop up on the fast view menu. 
Select “CodeWarrior Projects”  
from this menu to view the  
opened projects. 
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7. Click the lab project name to highlight 
it. Click the “Project > Clean…” menu 
item to bring up the Clean dialog. In 
this dialog, check “Clean projects 
selected below.” Select and check 
the project name. Check “Start a 
build immediately” and “Build only 
the selected projects” followed by 
pressing “OK.” This will start the project 
building process. When you see the 
“Finished building: …” message 
in Console view, the project building 
process is complete. 

8. Click the “Run > Debug 
Configurations…” menu item and the 
Debug Configurations dialog will pop 
up. In the Debug Configurations dialog, 
expand “CodeWarrior Download” and 
select “S08PT60_PnE MultiLink or 
OSBDM Connection.”

9. Click “Debug” to download code to 
the PT60. This starts the launching 
progress until the debugger perspective 
appears and stops at the line of main() 
in the source view.

Run and Debug Lab Code  
on TWR-S08PT60 Module

1. From the main menu, choose 
“Run > Resume” or click the 

Resume icon in the Debug view 
toolbar. The program will be executed 
in real time.

2. From the main menu, choose 
“Run > Suspend” or click the 

Suspend icon. The program execution 
will stop. The next instruction to be 
executed is highlighted in the source 
window.

3. From the main menu, choose 
“Run > Step Into” or click 

the Step Into icon. The instruction 
highlighted in the C source window 
will be executed and the program 
execution will be stopped immediately.
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Step-by-Step Installation Instructions (cont.)
4. From the main menu, choose 

“Run > Step Over” or click the 
Step Over icon. The debugger will 
execute the current statement and 
advance to the next statement in the 
source code. If the current statement 
is a routine call, program execution 
continues until it reaches: 

 		 end of the called routine, breakpoint, 
watchpoint, or an eventpoint that 
stops execution

5. From the main menu, choose 
“Run > Step Return” or click the 

Step Return icon. The debugger will 
execute the rest of the current routine 
and stop program execution after 
the routine returns to its caller. This 
command causes execution to return 
up the call chain.

6. From the main menu, choose 
“Run > Restart” or click the 

Restart icon. The debugger goes back 
to the beginning of the program and 
begins execution again. This behavior 
is equivalent to killing execution and 
starting a new debugging session.

7. From the main menu, choose  
“Run > Reset” or click the Reset 

icon. The debugger will reset the target.

8. Click on instruction stepping 
mode icon, you can debug the 

program in Disassembly View instead 
of the source view.

9. Now that you have successfully 
completed the software and hardware 
setup, you may continue to explore 
TWR-S08PT60 labs by following  
TWR-S08PT60 Labs Tutorial.
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the OSBDM, ensure that both J27 and 
J29 are open, then apply power to your 
target board.

4. Connect the provided USB cable from  
a free USB port on your computer to  
the mini-B USB connector on the  
TWR-S08PT60 module. Allow the  
PC to automatically configure the USB 
drivers as needed. USB drivers for your  
TWR-S08PT60 module were pre-loaded 
in the CodeWarrior installation.

5. Follow steps 3 and 4 to download 
CodeWarrior to your own board.

Learn  
More

After completing the steps in this  
quick start guide, take a look at the  
TWR-S08PT60 Labs Tutorial document 
(TWR-S08PT60_LAB) included in the 
Training section of the Getting Started 
DVD to learn more about how the 
MC9S08PT60 benefits your application.

Program Your Own Boards 
with TWR-S08PT60

You can also use TWR-S08PT60 OSBDM 
to program your own boards by following 
the steps below.

1. Configure J16 and J28 jumpers as below:

2. Connect J16 pin 1 to pin 1 of the target 
board BDM connector. Connect J28 
pin 1 to pin 4 of the target board BDM 
connector. Connect pin 2 of J23 to the 
pin 2 of the target board BDM connector. 
Connect pin 6 of J23 to the pin 6 of the 
target board BDM connector.

3. To power the target board using the 
OSBDM, ensure that a jumper on J27 is 
installed correctly per the power supply 
level and J29 is close to the default 
jumper settings. If you want your target 
board to be powered by itself instead of 

6
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Jumper Setting Description

J16 open OSBDM to on-board PT60

J28 open OSBDM to on-board PT60
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TWR-S08PT60 Default Jumper Options
The following is a list of all default jumper options.

Jumper Setting Description

J1 1 – 2 USB to UART2 (Rx)

J2 1 – 2 USB to UART2 (Tx)

J5 2 – 3 UART (SCI0 Tx)

5 – 6 UART (SCI0 Rx)

11 – 12 Infrared (Tx)

14 – 15 Infrared (Rx)

J6 3 – 5 UART (Rx to Tx)

J7 1 – 2 Potentiometer

J9 2 – 3 Accelerometer default address

J12 open Accelerometer INT1

J15 open Accelerometer INT2
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(continued from previous page)
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Jumper Setting Description

J16 1 – 2 OSBDM to on-board PT60 (BKGD)

J17 2 – 3 External clock (EXTAL)

J18 2 – 3 External clock (XTAL)

J20 2 – 3 TWRPI to PT60

J21 2 – 3 TWRPI to PT60

J22 2 – 3 TWRPI to PT60

J25 2 – 3 Power supply 5-volt selection

J26 2 – 3 Power supply 3.3-volt selection

J27 2 – 3 Power supply level selection

J28 1 – 2 OSBDM to on-board PT60 (/RESET)

J29 1 – 2 Power supply for PT60 and IDD measurement

Note: For some particular labs, special connections are required. For more information on these connections, 
consult the TWR-S08PT60 labs tutorial.



For more information, visit freescale.com/Tower

Join the online Tower community at towergeeks.org

Visit freescale.com/TWRS08PT60 for information  
on the TWR-S08PT60, including:

•	TWR-S08PT60 quick start guide
•	TWR-S08PT60 labs tutorial
•	TWR-S08PT60 user guide

Support
Visit freescale.com/support for a list of phone numbers 
within your region.

Warranty
One (1) year limited warranty. Please visit us at  
freescale.com/warranty for complete warranty information.

Freescale, the Freescale logo and CodeWarrior are trademarks or 
registered trademarks of Freescale Semiconductor, Inc. Reg. U.S. Pat. 
& Tm. Off. All other product or service names are the property of their 
respective owners. © 2011 Freescale Semiconductor, Inc. 

Doc Number: TWRS08PT60QSG REV 0
Agile Number: 926-78650 REV A
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Океан Электроники
Поставка электронных компонентов 

Компания «Океан Электроники» предлагает заключение долгосрочных отношений при 

поставках импортных электронных компонентов на взаимовыгодных условиях! 

Компания «Океан Электроники» является официальным дистрибьютором и эксклюзивным 
представителем в России одного из крупнейших производителей разъемов военного и 
аэрокосмического назначения «JONHON», а так же официальным дистрибьютором и 
эксклюзивным представителем в России производителя высокотехнологичных и надежных 
решений для передачи СВЧ сигналов «FORSTAR». 

Наши преимущества: 

- Поставка оригинальных импортных электронных компонентов напрямую с производств Америки, 
Европы и Азии, а так же с крупнейших складов мира; 
- Широкая линейка поставок активных и пассивных импортных электронных компонентов (более 
30 млн. наименований); 
- Поставка сложных, дефицитных, либо снятых с производства позиций; 
- Оперативные сроки поставки под заказ (от 5 рабочих дней); 
- Экспресс доставка в любую точку России; 
- Помощь Конструкторского Отдела и консультации квалифицированных инженеров; 
- Техническая поддержка проекта, помощь в подборе аналогов, поставка прототипов;  
- Поставка электронных компонентов под контролем ВП; 
- Система менеджмента качества сертифицирована по Международному стандарту ISO 9001; 
- При необходимости вся продукция военного и аэрокосмического назначения проходит 
испытания и сертификацию в лаборатории (по согласованию с заказчиком);
- Поставка специализированных компонентов военного и аэрокосмического уровня качества 
(Xilinx, Altera, Analog Devices, Intersil, Interpoint, Microsemi, Actel, Aeroflex, Peregrine, VPT, Syfer, 
Eurofarad, Texas Instruments, MS Kennedy, Miteq, Cobham, E2V, MA-COM, Hittite, Mini-Circuits, 
General Dynamics  и др.); 

«JONHON» (основан в 1970 г.)

Разъемы специального, военного и аэрокосмического 
назначения: 
(Применяются в военной, авиационной, аэрокосмической, 
морской, железнодорожной, горно- и нефтедобывающей 
отраслях промышленности) 

«FORSTAR» (основан в 1998 г.) 

ВЧ соединители, коаксиальные кабели, 
кабельные сборки и микроволновые компоненты: 

(Применяются в телекоммуникациях гражданского и 
специального назначения, в средствах связи, РЛС, а так же 
военной, авиационной и аэрокосмической отраслях 
промышленности). 

Телефон:    8 (812) 309-75-97 (многоканальный) 
Факс:           8 (812) 320-03-32 
Электронная почта:    ocean@oceanchips.ru 
Web:      http://oceanchips.ru/ 
Адрес:   198099, г. Санкт-Петербург, ул. Калинина, д. 2, корп. 4, лит. А


