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TWR-S08PT60
Freescale Tower System

The TWR-S08PT60 module is a part of the Freescale Tower System,
a modular development platform that enables rapid prototyping and
tool re-use through reconfigurable hardware. Elevate your design to
the next level and begin constructing your Tower System today.




TWR-S08PT60 Features

The TWR-S08PT6E0 Tower System module demonstrates the capability of
the MC9S08PT60 8-bit MCU targeted for industrial and home appliance
applications. It can function as a stand-alone, low-cost platform for the
evaluation of MC9S08PT60 devices. There is an OSBDM module on the
TWR-S08PT60 which can be used to debug MC9S08PTE0 devices on
both the TWR-S08PT60 module and external customer boards.

The MCOS08PTE0 is part of the 5-volt SO8PT family of MCUs, offering
exceptional EFT/ESD performance, more durability and reliability for
harsh industrial and user interface environments and alignment with the
IEC60730 appliance safety standard. The SO8P family is pin compatible
and integrates a touch-sensing interface (TSI), EEPROM and a motor
control flex timer to simplify designs and help reduce system costs.

MC9S08PT60 Features

e 8-bit SO8L core e Multiple timers, motor control,

e Upto 20 MHz CPU at 2.7-5.5 V PWM capable

e 60 KB flash, 4 KB RAM, 256B EE e Rich connectivity, including SCI,
e 12-bit ADC, 16-ch. SPland IPC

* Analog comparator e 57 GPIOs, including 8-pin, 20 mA
¢ 16-ch. touch-sensing input drive and 2-pin true open-drain



Quick Start Guide

Step-by-Step Installation Instructions

In this quick start guide, you will learn how to set up the TWR-S08PT60 module

and run the lab code.

1 Install Software
and Tools

Please insert the provided DVD into your
computer. After the initial screen appears,
install CodeWarrior development tools

in the order detailed below. Follow the
prompts through the installation of each
component, answering each prompt with
the default input.

1. Install CodeWarrior Development Studio
for Microcontrollers v10.1. Also install
CodeWarrior MCU v10.1 Update 1.0.1
(CW_MCU_V10.1_Update_1.0.1.zip) or
newer by following the instructions in
CodeWarrior_Service_Pack_Update_
Procedure.pdf found on the DVD.

2. Install CodeWarrior Service Pack for
MC9S08PT60 by following these steps:

* Open the CodeWarrior application
from the Windows Start menu

e Select the required workspace
and click “OK”

e Go to the Help menu in the
current window

e Select “Install New Software” item
from the drop down menu

In the “Install” dialog, click the “Add”
button in the upper right corner

In the “Add Site” dialog, fill your
favorite site name as the update
location in the “Name” text box and
click the “Archive” button

In the “Repository archive” browse
dialog, select the zip archive
containing the Service Pack Updater
Archive and click “Open”

e Open the “Work with:” drop down
list and select the update location you
have just added

e Select (check) the MCU Service
Pack “MCU V10.1 Serivce Pack
for MC9S08PT60” and uncheck
“Contact all updates sites during
install to find required software”
item, then click “Next”
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e Wait for the Updater to open the
archive and the “Install/Install
Details” dialog will appear. Select
the Service Pack and click “Finish.”
This will automatically install all the
Service Pack dependencies

e Select the “l accept the terms of
the license agreement” button and
click “Finish”

® You will be asked to restart
CodeWarrior again. Select “Yes”

Install PEMICRO Embedded Multilink

Toolkit (Terminal Window version 2.03

or newer is required for labs).

. Create a local workspace (folder) on

your computer, for example, PT60Lab.

. Install four CodeWarrior project files

by selecting the Training tab and unzip
these files to the local workspace that
was just created on your computer.

2 Set up the
TWR-S08PT60 Module

Remove the TWR-S08PT60 module from
anti-static pouch. Ensure the jumpers
are in the default positions as shown in
the Default Jumper Options table on the
following pages of this quick start guide.

After ensuring the jumpers are in the
default positions, connect provided USB
cable from a free USB port on your
computer to the mini-B USB connector on
the TWR-S08PT60 module. Allow the

PC to automatically configure the USB
drivers as needed. USB drivers for your
TWR-S08PT60 module were pre-loaded in
the CodeWarrior installation.



Quick Start Guide

Step-by-Step Installation Instructions (cont.)

3 Start CodeWarrior and
Debug Environment

1. Start CodeWarrior by selecting it from
the Windows Start menu.

2. From the CodeWarrior main menu,
choose “File > Switch Workspace”
and select “Other...” The Workspace
Launcher dialog appears where the
current (default) workspace name is
displayed on “Workspace:” edit text
box. If this workspace is not the one
on your computer that contains lab
projects, click “Browse...” to launch
the “Select Workspace Directory”
dialog. In this dialog, browse to the
project folder (workspace) containing
the lab projects and select it by clicking
“OK.” The project folder appears on
the “Workspace” text box. Click “OK”
to allow CodeWarrior to configure and
switch to the desired workspace.

3.

4.

o
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Click “File > Import...” menu item

to open Import dialog. In the Import
dialog, double click “General” and
select the “Existing Projects into
Workspace” item followed by selecting
“Next.” The Import Projects dialog
appears.

In the “Select root directory” dialog,
click “Browse...” Browse to and select
the project folder “TWR-S08PT60_
Lab1_6” followed by clicking “OK.”
The project name will appear in the
Projects list and will be checked. Ensure
“Copy projects into workspace” is
unchecked, and click “Finish.”

. When the Remote System Missing

dialog appears, click “Yes” until the
Welcome window appears. Close
this window.

=+ Click the fast view icon at the

! bottom left of the window which
will pop up on the fast view menu.
Select “CodeWarrior Projects”
from this menu to view the
opened projects.
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Click the lab project name to highlight
it. Click the “Project > Clean...” menu
item to bring up the Clean dialog. In
this dialog, check “Clean projects
selected below.” Select and check
the project name. Check “Start a
build immediately” and “Build only
the selected projects” followed by
pressing “OK.” This will start the project
building process. When you see the
“Finished building: ...” message

in Console view, the project building
process is complete.

. Click the “Run > Debug

Configurations...” menu item and the
Debug Configurations dialog will pop
up. In the Debug Configurations dialog,
expand “CodeWarrior Download” and
select “S08PT60_PnE MultiLink or
OSBDM Connection.”

. Click “Debug” to download code to

the PT60. This starts the launching
progress until the debugger perspective
appears and stops at the line of main()
in the source view.

1

3.

Run and Debug Lab Code
on TWR-S08PT60 Module

p' From the main menu, choose

=" “Run > Resume” or click the
Resume icon in the Debug view
toolbar. The program will be executed
in real time.

4

| From the main menu, choose

| “Run > Suspend” or click the
Suspend icon. The program execution
will stop. The next instruction to be
executed is highlighted in the source
window.

(5[0}

=, | From the main menu, choose
=7= “Run > Step Into” or click
the Step Into icon. The instruction
highlighted in the C source window
will be executed and the program
execution will be stopped immediately.



Quick Start Guide

Step-by-Step Installation Instructions (cont.)

4. =, From the main menu, choose

="1 “Run > Step Over” or click the
Step Over icon. The debugger will
execute the current statement and
advance to the next statement in the
source code. If the current statement
is a routine call, program execution
continues until it reaches:

end of the called routine, breakpoint,
watchpoint, or an eventpoint that
stops execution

. [~ | From the main menu, choose
.'[l'. “Run > Step Return” or click the
Step Return icon. The debugger will
execute the rest of the current routine
and stop program execution after
the routine returns to its caller. This
command causes execution to return
up the call chain.

6.

~
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P From the main menu, choose
| “Run > Restart” or click the
Restart icon. The debugger goes back
to the beginning of the program and
begins execution again. This behavior
is equivalent to killing execution and
starting a new debugging session.

From the main menu, choose
=1 “Run > Reset” or click the Reset
icon. The debugger will reset the target.

[, ] Click on instruction stepping

| mode icon, you can debug the
program in Disassembly View instead
of the source view.

Now that you have successfully
completed the software and hardware
setup, you may continue to explore
TWR-S08PT60 labs by following
TWR-S08PT60 Labs Tutorial.



5 Program Your Own Boards
with TWR-S08PT60

You can also use TWR-S08PT60 OSBDM
to program your own boards by following
the steps below.

1. Configure J16 and J28 jumpers as below:
I Jumper

Setting | Description

J16 open | OSBDM to on-board PTE0

J28 open | OSBDM to on-board PTE0

N

. Connect J16 pin 1 to pin 1 of the target
board BDM connector. Connect J28
pin 1 to pin 4 of the target board BDM
connector. Connect pin 2 of J23 to the
pin 2 of the target board BDM connector.
Connect pin 6 of J23 to the pin 6 of the
target board BDM connector.

3. To power the target board using the
OSBDM, ensure that a jumper on J27 is
installed correctly per the power supply
level and J29 is close to the default
jumper settings. If you want your target
board to be powered by itself instead of

the OSBDM, ensure that both J27 and
J29 are open, then apply power to your
target board.

4. Connect the provided USB cable from
a free USB port on your computer to
the mini-B USB connector on the
TWR-S08PT60 module. Allow the
PC to automatically configure the USB
drivers as needed. USB drivers for your
TWR-S08PT60 module were pre-loaded
in the CodeWarrior installation.

5. Follow steps 3 and 4 to download
CodeWarrior to your own board.

Learn
6 More

After completing the steps in this

quick start guide, take a look at the
TWR-S08PT60 Labs Tutorial document
(TWR-S08PT60_LAB) included in the
Training section of the Getting Started
DVD to learn more about how the
MC9S08PT6E0 benefits your application.
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TWR-S08PT60 Default Jumper Options

The following is a list of all default jumper options.

I Jumper Setting Description
J1 1-2 USB to UART2 (Rx)
J2 1-2 USB to UART2 (Tx)
J5 2-3 UART (SCIO Tx)
5-6 UART (SCIO Rx)
11-12 Infrared (Tx)
14 -15 Infrared (Rx)
J6 3-5 UART (Rx to Tx)
J7 1-2 Potentiometer
Jo 2-3 Accelerometer default address
J12 open Accelerometer INT1
J15 open Accelerometer INT2
10



(continued from previous page)

I Jumper Setting Description
J16 1-2 OSBDM to on-board PTE0 (BKGD)
J17 2-3 External clock (EXTAL)
J18 2-3 External clock (XTAL)
J20 2-3 TWRPI to PT60
J21 2-3 TWRPI to PT60
J22 2-3 TWRPI to PT60
J25 2-3 Power supply 5-volt selection
J26 2-8 Power supply 3.3-volt selection
J27 2-3 Power supply level selection
J28 1-2 OSBDM to on-board PTE0 (/RESET)
J29 1-2 Power supply for PT60 and IDD measurement

Note: For some particular labs, special connections are required. For more information on these connections,
consult the TWR-S08PT60 labs tutorial.
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Visit freescale.com/TWRS08PT60 for information
on the TWR-S08PTE0, including:

* TWR-S08PT60 quick start guide
* TWR-S08PT60 labs tutorial
* TWR-S08PT60 user guide

Support

Visit freescale.com/support for a list of phone numbers
within your region.

Warranty

One (1) year limited warranty. Please visit us at
freescale.com/warranty for complete warranty information.

For more information, visit freescale.com/Tower

Join the online Tower community at towergeeks.org

Freescale, the Freescale logo and CodeWarrior are trademarks or
registered trademarks of Freescale Semiconductor, Inc. Reg. U.S. Pat.
& Tm. Off. All other product or service names are the property of their
respective owners. © 2011 Freescale Semiconductor, Inc.

Doc Number: TWRS08PT60QSG REV 0
Agile Number: 926-78650 REV A



OCEAN CHIPS

OxreaH INeKTPOHMUKM
MocTaBKa 3ﬂeKTp0HHbIX KOMMOHEHTOB

Komnanusa «OkeaH DNEKTPOHMKM> MpEeAaraeT 3aK/Il04EHUE JONTOCPOYHbIX OTHOLLIEHMM NpU
MOCTaBKaX MMMOPTHbIX 3/1EKTPOHHbIX KOMMOHEHTOB HA B3aMMOBbIrOZHbIX YC10BMAX!

Hawwu npeumyliectsa:

- NlocTaBKa OpMrMHaIbHbIX UMMNOPTHbBIX 3/IEKTPOHHbIX KOMMOHEHTOB HanNpAMYy C NPOM3BOACTB AMEPUKM,
EBponbl M A3uK, a TaK e C KpYNHEMLIMX CKIaJ0B MMPa;

- LUnMpoKas sMHeMKa NOCTaBOK aKTUBHBIX M MACCMBHBIX MMMOPTHbBIX 3/1EKTPOHHbIX KOMMOHEHTOB (6onee
30 MJIH. HAMMEHOBAHUMN);

- MocTaBKa C/IOXKHbIX, AeDUUMUTHBIX, IM60 CHATLIX C NPOM3BOACTBA NO3ULMIA;

- OnepaTMBHbIE CPOKM NOCTABKM NOA 3aKa3 (0T 5 paboumx AHEN);

- JKCnpecc JoCTaBKa B 06YH0 TOYKY Poccuu;

- Momouwb KoHcTpyKTOpCKOro OTAena 1 KOHCynbTauumu KBaMPULUUPOBAHHBIX MHXEHEPOB;

- TexHM4ecKaa nogaepkka NpoeKTa, NomMollb B NoA6ope aHanoros, NocTaBka NPOTOTUNOB;

- [locTaBKa 3/1EKTPOHHbIX KOMMOHEHTOB NoJ, KOHTposiem BIT;

- CUcTeMa MeHeaXXMeHTa KayecTBa cepTudmumpoBaHa no MexayHapogHomy ctaHgapTy 1SO 9001;

- Mp1 HEO06XOAMMOCTH BCA NPOAYKLUMA BOEHHOIO M adPOKOCMMYECKOrO Ha3HaYeHMA NPOXoAUT

MCMbITaHMA M CEPTUMhMKALMIO B TaGOPATOPMM (MO COrIACOBAHMIO C 3aKa34YMKOM);
- MocTaBKa cneumanusmMpoBaHHbIX KOMMOHEHTOB BOEHHOMO M a3POKOCMMYECKOr0 YPOBHSA KayecTBa

(Xilinx, Altera, Analog Devices, Intersil, Interpoint, Microsemi, Actel, Aeroflex, Peregrine, VPT, Syfer,
Eurofarad, Texas Instruments, MS Kennedy, Miteq, Cobham, E2V, MA-COM, Hittite, Mini-Circuits,
General Dynamics u gp.);

KomnaHua «OkeaH JNEeKTPOHMKKU» ABNAETCA oduuMabHbIM AUCTPUOLIOTOPOM M SKCKJIHO3MBHbBIM
npesctasuteneM B Poccum ofHOrO M3  KpPYMHEMWMX MPOM3BOAMUTENIEM Pa3beEMOB BOEHHOMO W
A3pPOKOCMMYECKOro Ha3sHavyeHuMs <«JONHON», a Tak Xe oduuMaibHbiIM AUCTPUOBIOTOPOM MU
JKCK/II03MBHbIM nNpeacTaBuTenieM B Poccvn npousBoauTENA BbICOKOTEXHOIOMMYHBIX M HaAEXHbIX
peweHun ans nepeaaym CBY curHano «FORSTAR>.

«JONHON> (ocHosaH B 1970 T.)

PasbeMbl crneumanbHOro, BOEHHOMo M A3POKOCMHNYECKOIo
Ha3Ha4YeHHA:

JONHON (MpuMeHsOTCA B BOEHHOM, aBMALMOHHOM, a3POKOCMMYECKOM,

MOPCKOM, KeNe3HOAOPOXKHOM, TOpHO- M HedTeao6biBatoLLeN
0Tpac/AX NPOMbILLIEHHOCTH)

«FORSTAR> (ocHoBaH B 1998 r.)

BY coegmHmnTENN, KOAKCHaNbHbIE Kabenn

’ ) ®
KabenbHble COOPKM M MMKPOBONIHOBbIE KOMMOHEHTbI: FORS 'AR
L

(MpuMeHsaTCA B TEJIEKOMMYHMKAUMAX  FPaXXAaHCKOro M
cneuManbHOrO HasHayeHus, B cpeacTBax cBA3sM, PJIC, a TaK xe
BOEHHOM,  aBMALUMOHHOM M AdPOKOCMMYECKOM  OTpacisx
NPOMBILLNIEHHOCTH).

TenedoH: 8 (812) 309-75-97 (MHOroKaHasbHbIN)

dakc: 8 (812) 320-03-32

DNIeKTpPOHHas noyTa: ocean@oceanchips.ru

Web: http://oceanchips.ru/

Appec: 198099, r. CaHkT-leTepbypr, yn. KananHuHa, 4. 2, Kopn. 4, amT. A




