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Figure 1  ML62Q1000 Capacitive Switch Starter Kit hardware configuration 
 
■ Use in a stand-alone 

The ML62Q1367 DTMF Tone Generator Sample Program (hereinafter “DTMF Sample Program”) is being written in the flash 
memory at the time of shipment.  
The following description applies to use in a stand-alone. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2  Use in a stand-alone configuration 

 

• AC – USB power supply are to be supplied by our customers.  

If you connect the ML62Q1367 Capacitive Switch Application Board to your PC by the USB cable, power is supplied to 

it. 

 
1. Connection and launch of the DTMF Sample Program 
1-1. As shown in figure 1 and figure 2, connect the speaker and the USB cable to the ML62Q1367 Capacitive Switch Application 

Board. 
1-2. Connect the USB cable to power supply. 

The DTMF Sample Program will start, display “LAPIS” on the LCD and sound a beep. 
 

 
 
 

Figure 3  Display of the LCD after starting 

 

1-3. Touch a capacitive switch key of the ML62Q1367 Capacitive Switch Application Board.  
The DTMF Sample Program sounds a DTMF tone corresponding to a touched capacitive switch key and displays a character to 
on the LCD. 
 
 
 
 
 

Figure 4  Display example of the LCD after touching capacitive switch key [TSW12] 

  of the ML62Q1367 Capacitive Switch Application Board. 

 
2. Shut down 
2-1. Disconnect the USB cable from power supply. 
 

 
 
 
 
 
■ Use with the U8/U16 Development Tools 

This section will take you through the process of building the DTMF Sample Program, loading to the ML62Q1367 Capacitive Switch 
Application Board and running. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5  Use with the U8/U16 Development Tools configuration 

 
 
3. Copy of ML62Q1000 Capacitive Switch Starter Kit Software Package to your PC 
3-1. Insert the “ML62Q1000 Capacitive Switch Starter Kit Software Package” DVD into the DVD drive of your PC. 
3-2. Copy the “ML62Q1000_CAP_Switch_StarterKit” folder in the DVD to the C drive’s root folder (C:\) of your PC. 

• Please copy the “ML62Q1000_CAP_Switch_StarterKit” folder to the folder the name of which is using half-width 

characters except space if you do not copy it to the C drive’s root folder (C:\) of your PC. 
 

3-3. Eject the DVD from the DVD drive of your PC. 

 
4. Installation of U8/U16 Development Tools 

This section will take you through the process of installing the U8/U16 Development Tools software, the Multiple Flash Writer, the 
Device Information Files and the EASE1000 V2 USB drivers. 
 

• Operating environment：Windows 7*, Windows 8.1*, Windows 10*   * 32-bit (x86) and 64-bit (x64) version. 

• Please log on as an administrator account. 

• When U8/U16 Development Tools existing in your PC, uninstall these programs at the beginning.  

For uninstallation, refer to Step #11. 

 
4-1. Extract the archives of the U8DevTool_Rx_xx_x.zip in the “ML62Q1000_CAP_Switch_StarterKit” folder that you copied in 

Step #3. 
*” Rx_xx_x” depends on the release version of the U8/U16 Development Tools. 

 
4-2. Double-click the U8DevInstaller.exe file in the “Setup” folder into which you extracted the U8DevTool_Rx_xx_x.zip. 

When this file is executed, the InstallShield Wizard will install the U8/U16 Development Tools software, the Multiple Flash 
Writer, the Device Information File and the EASE1000 V2 USB driver. 
 

• Follow the instructions of the InstallShield wizard to install.  

• Agree to “SOFTWARE LICENSE AGREEMENT for SOFTWARE DEVELOPMENT TOOLS”. 

• Do not change option settings. 

• Select “Complete” in the Setup Type selection part. 
 
When the InstallShield Wizard displays the “InstallShield Wizard Completed” message box finally, close it. 
After that, installation has finished. 

 
5. Connection 
5-1. As shown in figure 1 and figure 5, connect the ML62Q1367 Capacitive Switch Application Board to the EASE1000 V2 On-Chip 

Emulator (hereinafter “EASE1000”). 
5-2. Connect the EASE1000 to PC using the USB cable. 

In case of Windows7, if you first connect EASE1000 to PC, the messages as the following Figure 6 and Figure 7 are displayed in 
sequence. 
 

 
 
 

Figure 6  The USB driver installation message 1              Figure 7  The USB driver installation message 2 

5-3. Connect the speaker to the ML62Q1367 Capacitive Switch Application Board. 
5-4. Connect the ML62Q1367 Capacitive Switch Application Board to PC using the USB cable. 
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6. Installing the DTMF Sample Program 
6-1. Extract the archives of the CAP_Switch_SampleProgram.zip in the “ML62Q1000_CAP_Switch_StarterKit” folder that you copied 

in Step #3. 
ML62Q1000 Capacitive Switch Starter Kit Sample Programs including the ML62Q1367 DTMF Tone Generator Sample Program 
will be extracted into the “ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram\Software” folder. 
 

7. Build of the ML62Q1367 DTMF Tone Generator Sample Program and Launch of the DTU8 debugger 
This section will take you through the process of building the DTMF Sample Program and launching the DTU8 debugger. 
 
You can select 2 methods to build the DTMF Sample Program. 

• Using the Integrated Development Environment “IDEU8” (hereinafter “IDEU8”) 
You build the DTMF Sample Program by using the IDEU8. 
Continue to Step “7a : In case of the IDEU8”. 

• Using the Eclipse-based LEXIDE-U16 Integrated Development Environment (hereinafter “LEXIDE-U16”) 
You build the DTMF Sample Program by using the LEXIDE-U16 after you import the IDEU8 project file. 
Continue to Step “7b : In case of the Eclipse-based LEXIDE-U16”. 

 
<7a : In case of the IDEU8 > 

This section will take you through the process of building the DTMF Sample Program by using the IDEU8, launching the DTU8 
debugger from the IDEU8 and loading the DTMF Sample Program to the ML62Q1367. 
 

• For details regarding the IDEU8, refer to the “IDEU8 User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > IDEU8 User’s Manual 
On the Window10: Start Menu > U8 Tools > IDEU8 User’s Manual 
 

7-1. Launch the IDEU8 from the Start Menu. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 > IDEU8 GUI Environment 
On the Window10: Start Menu > U8 Tools > IDEU8 GUI Environment 

7-2. Select the [File] menu > [Open... menu] command of the IDEU8. 
7-3. In the [Open File] dialog box, select the DtmfSample.PID which was extracted into the 

“ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram\Software\01_Dtmf_vXXX\Software\examples\DtmfSampl
e” folder in Step #6-1. 
                                                    *”vXXX” depends on the version of the DTMF Sample Program. 
 
The project file of the DTMF Sample Program will be opened. 
 

7-4. Click the [Build] button to compile, assemble and link the DTMF Sample Program. 
  

 
You will be able to see the message “Finished building.” 

 
 

7-5. Click the [Debug] button to launch the DTU8 debugger 
 
 
 

7-6. In the “Target Settings” dialog box, select “ML621367” from LSI list of the “ML62Q1000” Category / ”ML62Q1300” Group of 
“Target chip”, and select ”On Chip Emulator” from the “Target ICE” list. And Click the [OK] button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8  Select the target chip and the target ICE 

 

7-7. Click the [OK] button when a confirmation dialog box will be displayed that asks the user whether to start debugging. 
The DTU8 debugger will load the DTMF Sample Program. 
After finishing loading, the DTU8 debugger will display a source window as the following Figure 9. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 9  The DTU8 debugger 
 
Continue to Step #8 “Run of the DTMF Sample Program by the DTU8 debugger” 
 

 
 
 
 
 

<7b :  In case of the Eclipse-based LEXIDE-U16 > 
This section will take you through the process of importing the IDEU8 project file of the DTMF Sample Program by using the 
LEXIDE-U16, building the DTMF Sample Program, launching the DTU8 debugger and loading the DTMF Sample Program to 
the ML62Q1367. 
 

• For details regarding the LEXIDE-U16, refer to the “LEXIDE-U16 User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > LEXIDE-U16 User’s Manual 
On the Window10: Start Menu > U8 Tools > LEXIDE-U16 User’s Manual 

 
7-8. Launch the LEXIDE-U16 from the Start Menu. 

On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 > LEXIDE-U16 
On the Window10: Start Menu > U8 Tools > LEXIDE-U16 

The LEXIDE-U16 will display [Select a directory as workspace] dialog box after displaying a Splash Screen. 
7-9. In the [Workspace] field of the [Select a directory as workspace] dialog box, select the 

“ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram\Software” folder which was extracted the 
CAP_Switch_SampleProgram.zip in Step #6-1. 
And click the [Launch]. 
 

 
 
 
 
 
 
 

Figure 10  Select a “Workspace” folder in the [Workspace] field  
       of the [Select a directory as workspace] dialog box. 

 
A little while, the LEXIDE-U16 will launch. 
 

7-10. Select the [File] menu > [ Import…] menu command of the LEXIDE-U16. 
The [Import] dialog box will be opened. 

7-11. Select [LAPIS] > [IDEU8 project file(*.PID)] in the [Import] dialog box and click [Next] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11  Select [LAPIS] > [IDEU8 project file(*.PID)] in the [Import] dialog box 
 
The [Import PID file] dialog box will be opened. 
 

7-12. Select “ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram\Software\01_Dtmf_vXXX\Software\examples\ 
DtmfSample” folder in the [Project path] field of the [Import PID file] dialog box. 
The selected folder contains the DTMF Sample Program project file of the IDEU8. 

                                   *”vXXX” depends on the version of the DTMF Sample Programe. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 12  Select “Project path” in the [Project path] of the [Import PID file] dialog box 
 

The DTMF Sample Program project file of the IDEU8 will be displayed in the [Import PID file] dialog box. 
 

7-13. Select the [DtmfSample.PID] which is displayed in the [Project list] field of the [Import PID file] dialog box. And click the 
[Finish] button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13  Select the DTMF Sample Program project file of the IDEU8  
in the [Import PID file] dialog box 

 
The DTMF Sample Program project file of the IDEU8 will be imported to the LEXIDE-U16. 
 



 
 
 
 
 
 

7-14. Click the [Open Perspective] button in the top right of the LEXIDE-U16. 
 
 

 
The [Open Perspective] dialog box will be displayed. 
 

7-15. Select the [C/C++] in the [Open Perspective] dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 14  Select the [C/C++] in the [Open Perspective] dialog box. 
 
The toolbar will be changed for the [C/C++ Perspective] as the following Figure15. 

 
 
 

Figure 15  The [C/C++ Perspective] toolbar 
 

7-16. Select the [DtmfSample] of the [Project Explorer]. 
 
 
 
 
 
 
 
 
 

Figure 16  Select the [DtmfSample] of the LEXIDE-U16’s [Project Explorer] 
 

7-17. Click the [Build] button to compile, assemble and link the DTMF Sample Program. 
 
 
 

 
You will be able to see the message “Build Finished.” 
 

7-18. Click the [LAPIS] menu > [Debug(DTU8)] menu comamd to launch the DTU8 debugger and load the DTMF Sample Program. 
 
 
 
 
 
 
 
 
 

Figure 17  Select the [LAPIS] menu > [Debug(DTU8)] 
 

• You cannot use [RUN] menu command to launch the DTU8 debugger. 
 
The DTU8 debugger will launch and load the DTMF Sample Program. 
After finishing loading, the DTU8 debugger will display a source window as the following Figure 18. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 18  The DTU8 debugger 

 
 
 
 
 

8. Run of the DTMF Sample Program by the DTU8 debugger 
8-1. Click the [Reset and Restart] button of the DTU8 debugger 

 
 
 
 
 
The DTMF Sample Program will start the same using a stand-alone. 
 

• For details regarding the DTU8 debugger, refer to the “DTU8 debugger User’s manual”. 
On the Windows 7: Start Menu > All Programs > U8 Tools > nX-U8 Documents > DTU8 User’s Manual 
On the Window10: Start Menu > U8 Tools > DTU8User’s Manual 

 
9. Stop of the DTMF Sample Program 
9-1. Click the [Stop] button of the DTU8 debugger. 

The DTMF Sample Program will stop. 
 

10. Shut down 
< DTU8 Debugger> 

10-1. Select the [File] menu > [Exit] menu command of the DTU8 debugger. 
10-2. Click the [OK] button when a confirmation dialog box will be displayed that asks the user whether to terminate DTU8 debugger.  
10-3. Click the [No] button when a confirmation dialog box will be displayed that asks the user whether to save current settings to 

project file.  
The DTU8 debugger will shut down. 
 

<In using IDEU8 case > 
10-4. Select the [File] menu > [Exit] menu command of the IDEU8 
10-5. Click the [Yes] button when a confirmation dialog box will be displayed that asks the user whether to stop IDEU8. 
10-6. Click the [Yes] button when a confirmation dialog box will be displayed that asks the user whether to save current settings to 

project file. 
The IDEU8 will shut down. 
Continue to Step #10-8 
 

<In using LEXIDE-U16 case > 
10-7. Select the [File] menu > [Exit] menu command of the LEXIDE-U16 

The LEXIDE-U16will shut down. 
 

<Hardware > 
10-8. Disconnect the USB cable which is connected to the ML62Q1367 Capacitive Switch Application Board from your PC. 
10-9. Disconnect the USB cable which is connected to the EASE1000 from your PC. 

 
11. Uninstallation 

• Uninstalling U8/U16 Development Tools Release 2.00.0 or later 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Environment Setup : LAPIS Semiconductor U8/U16 Development Environment Setup 

 

You will be able to uninstall all of the bellow U8/U16 Development Tools. 

- U8/U16 Development Tools software (build tools) : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Development Tools software (GUI tools) : LAPIS Semiconductor U8/U16 Development Tools 

- Multiple Flash Writer   : LAPIS Semiconductor MWU16 Multiple Flash Writer 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver 
 

• Uninstalling U8/U16 Development Tools Release 2.00.0 than earlier. (Not include Release 2.00.0) 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Tools software  : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver*1 

*1: There is not USB driver in the U8/U16 Development Tools Release 1.15.4 than earlier. 
 

12. The Software Development Support System 
When you need the latest version of the U8/U16 Development Tools software and the ML62Q1000 Series Reference Software, 
you can download the latest version from “LAPIS Semiconductor support site” (hereinafter “Support Site”) is a special website 
that gives registered users. 
Registration is required to access the site using an ID and Password. 
Navigate to the support page by clicking on a link on LAPIS Semiconductor's home page or by entering the URL in the browser's 
address bar. Then click on the 'Register' link. 

LAPIS Semiconductor support site URL 
https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi 

 
* In order to download the software such as the software development support system, you need to register the 

serial number of the EASE1000 V2at the time of registration.  
At the time of registration, select “Microcontroller / speech Synthesis LSI”, "EASE1000 V2 " and type "The 
serial number of EASE1000 V2" as follows. 
 

Category: Microcontroller / speech Synthesis LSI 
Development/evaluation tool name: EASE1000 V2 
The serial number of development tool: The serial number of EASE1000 V2 

 
 
  

https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi
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Appendices Figure 3. Blank sheet  Appendices Figure 2. DTMF Sample Program key’s sheet 

=== Appendices: Capacitive switch key sheets == 
Use capacitive switch key’s sheets to insert between the ML62Q1367 Capacitive Switch Application Board and an acrylic as follows. 

Appendices Figure 1 
The ML62Q1367 Capacitive Switch Application Board  

which is inserted the DTMF Sample Program key’s sheet. 



Mouser Electronics
  

Authorized Distributor
 
  

Click to View Pricing, Inventory, Delivery & Lifecycle Information:
 
 
 
 ROHM Semiconductor:   

  SK-AD01-D62Q1367TB

https://www.mouser.com/rohm-semiconductor
https://www.mouser.com/access/?pn=SK-AD01-D62Q1367TB


Океан Электроники
Поставка электронных компонентов 

Компания «Океан Электроники» предлагает заключение долгосрочных отношений при 

поставках импортных электронных компонентов на взаимовыгодных условиях! 

Компания «Океан Электроники» является официальным дистрибьютором и эксклюзивным 
представителем в России одного из крупнейших производителей разъемов военного и 
аэрокосмического назначения «JONHON», а так же официальным дистрибьютором и 
эксклюзивным представителем в России производителя высокотехнологичных и надежных 
решений для передачи СВЧ сигналов «FORSTAR». 

Наши преимущества: 

- Поставка оригинальных импортных электронных компонентов напрямую с производств Америки, 
Европы и Азии, а так же с крупнейших складов мира; 
- Широкая линейка поставок активных и пассивных импортных электронных компонентов (более 
30 млн. наименований); 
- Поставка сложных, дефицитных, либо снятых с производства позиций; 
- Оперативные сроки поставки под заказ (от 5 рабочих дней); 
- Экспресс доставка в любую точку России; 
- Помощь Конструкторского Отдела и консультации квалифицированных инженеров; 
- Техническая поддержка проекта, помощь в подборе аналогов, поставка прототипов;  
- Поставка электронных компонентов под контролем ВП; 
- Система менеджмента качества сертифицирована по Международному стандарту ISO 9001; 
- При необходимости вся продукция военного и аэрокосмического назначения проходит 
испытания и сертификацию в лаборатории (по согласованию с заказчиком);
- Поставка специализированных компонентов военного и аэрокосмического уровня качества 
(Xilinx, Altera, Analog Devices, Intersil, Interpoint, Microsemi, Actel, Aeroflex, Peregrine, VPT, Syfer, 
Eurofarad, Texas Instruments, MS Kennedy, Miteq, Cobham, E2V, MA-COM, Hittite, Mini-Circuits, 
General Dynamics  и др.); 

«JONHON» (основан в 1970 г.)

Разъемы специального, военного и аэрокосмического 
назначения: 
(Применяются в военной, авиационной, аэрокосмической, 
морской, железнодорожной, горно- и нефтедобывающей 
отраслях промышленности) 

«FORSTAR» (основан в 1998 г.) 

ВЧ соединители, коаксиальные кабели, 
кабельные сборки и микроволновые компоненты: 

(Применяются в телекоммуникациях гражданского и 
специального назначения, в средствах связи, РЛС, а так же 
военной, авиационной и аэрокосмической отраслях 
промышленности). 

Телефон:    8 (812) 309-75-97 (многоканальный) 
Факс:           8 (812) 320-03-32 
Электронная почта:    ocean@oceanchips.ru 
Web:      http://oceanchips.ru/ 
Адрес:   198099, г. Санкт-Петербург, ул. Калинина, д. 2, корп. 4, лит. А


