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1. Description 
 

This user guide provides an introduction to Workshop 4, the 4D Systems integrated development environment. 

Workshop 4 supports multiple development environments for the user, to cater for different user 

requirements and skill level. 

 
 
The Designer environment enables the user to write 4DGL code in its natural form to 
program the 4D Systems module of choice.  
 
 
 
 
 
A visual programming experience, suitably called ViSi, enables drag-and-drop type 
placement of objects to assist with 4DGL code generation and allows the user to visualise 
how the display will look while being developed.  
 
 
 
 
An advanced environment called ViSi-Genie doesn’t require any 4DGL coding at all, it is all 
done automatically. Simply lay the display out with the objects required, set the events to 
drive them and the code is written for the user automatically. ViSi-Genie provides the 
latest rapid development experience from 4D Systems. (Not available for Goldelox) 
 

 
 
A Serial environment is also provided to transform the 4D Systems module into a slave 
serial module, allowing the user to control the display from any host microcontroller or 
device with a serial port. 
 
 

 
To install Workshop 4, please refer to the document Workshop 4 Installation. 
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2. Workshop 4 
 

There is an alias for 4D Workshop on the desktop: 

 

Launch 4D Workshop by double-clicking on the icon: 
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3. Create a New Project 
 

Workshop 4 opens and displays the Recent page: 

 

 

To create a new program, there are multiple options: 

 Click on the top left-most icon New 
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 Click on the upper Create a New Project if creating a project from scratch, or click on the lower Create 

a New Project to use the settings and module that was used last time: 

 

 

Choose Your Product, simply select the 4D Systems module of choice to start your development: 

 

 

Select the product, in this case the µLCD-32PT Display Module: 
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The selected module is displayed on the right hand side: 

 

 

Orientation is portrait by default. 

To set it to landscape, just click on the image of the display to rotate it. Additional clicks rotate the display by 

90 degrees: 

 

 

Press Next to proceed: 
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4. Choose Your Environment 
 

The main window now asks for the environment for the project: 

 

Four main environment options are available: 

 Designer, 

 ViSi, 

 ViSi-Genie,  

 Serial 

 

…and two editor options: 

 Create System File, 

 Create Text File.  

  

Each option opens a customised environment with specific commands and controls. 

Different projects using different modules and environments can be open simultaneously on Workshop 4. The 

toolbar ribbon will adapt to the project tab that is selected, to suit its environment.  
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 Designer 

 

 

The Designer environment enables the user to write 4DGL code in its natural form to program the display 

module. 4DGL is a graphics oriented language allowing rapid application development, and the syntax structure 

was designed using elements of popular languages such as C, Basic, Pascal and others. 

 

 

 

To learn more about Designer, please to refer to the 4DGL Internal Functions Reference Manuals and 4DGL 
Programmers Reference Manual on the Workshop 4 product page of the website, and the related application 
notes on the Application Note page of the website. http://www.4dsystems.com.au  
 

http://www.4dsystems.com.au/
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 ViSi 

 

 

A visual programming experience, suitably called ViSi, enables drag-and-drop type placement of objects to 

assist with 4DGL code generation and allows the user to visualise how the display will look while being 

developed. 

 

 

 

To learn more about ViSi, please to refer to the ViSi User Guide on the Workshop 4 product page of the 
website, and the related application notes on the Application Note page of the website. 
http://www.4dsystems.com.au 
 
 

 

http://www.4dsystems.com.au/
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 ViSi-Genie 

 

 

An advanced environment called ViSi-Genie doesn’t require any 4DGL coding at all, it is all done for the user. By 

simply laying the display out with the wanted objects and setting the events to drive them, the code is written 

automatically. ViSi-Genie provides the latest apid development experience from 4D Systems. 

 

 

 

To learn more about ViSi-Genie, please to refer to ViSi-Genie User Guide on the Workshop 4 product page of 
the website, and the related application notes on the Application Note page of the website. 
http://www.4dsystems.com.au 
 

http://www.4dsystems.com.au/
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 Serial 

 

 

The Serial environment is provided to transform the module into a slave serial module, allowing 

communication and control from virtually any host micro-controller or device with a serial port. 

 
For detail on this environment and steps on how to make your display module run under the Serial 
environment, please refer to the Serial Command Set Reference Manual on the Workshop 4 product page of 
the website, and the related application notes on the Application Note page of the website. 
http://www.4dsystems.com.au 
 

  

http://www.4dsystems.com.au/
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 Create System File 

 

The Create System File option provides an editor for all 4DGL-related projects, so a user can create or edit a 

4DGL Include file, 4DGL Library file, a Function or System file. These can then be included in the users 4DGL 

code. 
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 Create Text File 

 

The Create Text File environment features a plain editor, suitable for writing basic documentation, application 

notes, data files or anything else requiring plain text files. 
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5. Common File Menu 
 
The File Menu is the first menu and common to all environments… 

 

…with various buttons relating to the project that is open (or greyed out if no project is open): 

• File-related buttons, 

• Print-related buttons, 

• And miscellaneous buttons, such as Help, Options and Samples. 

 File-Related Buttons 
 

The buttons include all the actions related to projects: New, Open, Recent, Save, Save As, Zip Project and Close 

project. 
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The options include: 

• Click New to create a new project. A dialogue window asks for the screen and the kind of project. 

 

• Click Open to browse and open an existing project. A standard Open window opens.  

 

Select ViSi-Genie projects among the different kinds listed below to load a ViSi-Genie project: 
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• Click Recent to list the recently accessed files, and click on the project to open it. 

 

• Click Save to save the modified projects.  

• Click Save As to create a copy of already saved project and give it a new name. A standard Save 

window opens and asks for the location and the name: 

 

 Click Zip Project to make a compressed file out of the project. This is especially useful when then 

project is large and contains pictures and videos. 
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 Click Close to close the current project. You will be prompted to save the changes to any modified 

project. 

 

 Print-Related Buttons 
 
The buttons include all the actions related to print: 

 

Click Print Setup to setup the printer: 
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Click Print to print the project: 

 

 Miscellaneous Buttons  

 

The Miscellaneous buttons include Options, Help, Samples and Exit. 

 

Click Options to set the options for the current project: 
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Options include three panes but only Environment is relevant with ViSi-Genie, which is code-less. The Compiler 

and Editor panes deal with code. 

 

Select the Style among different possibilities. 

The Image / Video Resample Quality selection brings different options: 

o Fastest 

o Scaled 

o Box 

o Spline 

o Bilinear 

o Bicubic 

o Lanczos 

Click Help to access help, with links to the 4D Systems website: 
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Click Samples to access examples from 4D Systems, with pre-defined filters: 

 
 

Click Exit to close Workshop 4. You will be prompted to save the changes to any modified project. 

 

6. Designer Specific Menus 
 

The Designer environment includes five menus: 

 

 Home Menu 
 

The Home menu is the main menu… 

 

…with three groups of buttons: 

• File-related commands, 

• Build command, 

• And the objects pane. 

6.1.1. File-Related Buttons 

 

The file-related buttons include the same commands as seen in the File menu: New, Open, Save, Save As and 

Print. 
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6.1.2. Code Related-Buttons 

 
The code related buttons include the standard Windows commands of Cut, Copy, Paste, Delete, Undo and 

Redo. 

 

6.1.3. Bookmark Buttons 
 

The bookmark buttons include Set a bookmark, go to Next or Previous bookmark and Clear All bookmarks. 

 

Bookmarks are shown close to the line number: 

 

Bookmarks are especially useful for large projects. 

6.1.4. Find and Replace Buttons 

 
The find and replace buttons provide the basic features for code. 
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The Find button prompts for a string and highly it in the code: 

 

Use the up and down arrows to look for the previous and next occurrence. Check Whole Words and Case 

Sensitive. Choose between This file and Files in progress and All Open Files. 

 

The Replace button searches for a string and exchanges it with another string: 

 

Same options as for Find apply. 

The Goto button prompts for a line number: 
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6.1.5. Code Folding Buttons 
 

The code folding buttons allow to collapse or expand a function: 

 

This is especially useful for large projects. 

6.1.6. Compile Buttons 
 

The Compile button launches the compilation of the project while the Comp’nLoad compiles and uploads the 

project to the screen. 

 

 Menu Tools 

 

 

All the tools and utilities are grouped here: 

• Click PmmC Loader to start the PmmC Loader utility. 

• Click ‘Terminal connect 9600’ to open the currently selected com port at 9600 baud in the 

Terminal program. 

• Click ‘Terminal connect 115200’ to open the currently selected com port at 115200 baud in the 

Terminal program. 

• Click Touch Calibration to calibrate the touch on the display. 

• Click 4DGL uVGA Link to open a window which can interact with the uVGA, enabling a mouse and 

keyboard to be used with the uVGA(GFX) module. Demo code is available from Workshop 4.   

 Comms Menu 
 

This menu is in charge of the communication port: 

 

The use of this menu is described at the section Connect the Module. 
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 Project Menu 
 

The Project menu includes different parameters and options… 

 

…with two groups of buttons: 

• Destination, 

• And display selection. 

6.4.1. Destination 
 

The first group includes the options for the destination: 

 

Select the Destination among two possibilities: 

 RAM means the display must be connected during build and that the program will be downloaded to 

the display’s RAM memory once compiled. If RAM is chosen as the destination, the program is lost 

when the display is turned off. 

 Flash means the display must be connected during build and that the program will be downloaded to 

the display’s flash memory once compiled. If flash is chosen as the destination, the program is 

retained and will be available after power cycling. 

  



4D SYSTEMS                                                                            Workshop 4 User Guide 
 

 

 © 2014 4D SYSTEMS                       Page 27 of 37                    www.4dsystems.com.au 

W
or

ks
h
op

 4
 U

se
r 

G
ui

d
e 

6.4.2. Display Selection 
 

The second section allows to select the screen. Clicking on the button… 

 

…opens a new window to select the screen: 

 

Select the screen from the drop-down list: 

 

Define the orientation among the four options: 

 

Confirm by clicking on   or deny by clicking on . 
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7.  ViSi Specific Menus 
 

The ViSi environment includes all the menus available with the Designer environment plus two additional 

menus: View and Widgets. 

 
 

 View Menu 
 

The View menu includes one important tool for visualising the form: 

 
 

Click on Snapshot to open a specific window of the form to enable a 1:1 screenshot of the display to me made. 

 

This window provides a zoom up to 4 times. The Save button allows to save the screen as an image. 

 

Object Inspector, Form, and Reset View, all relate to the menus and tool bars used in Workshop 4. These 

toolbars and menus can be moved and detached from the side of Workshop 4. Object Inspector and Form will 

bring to front the relevant toolbar when clicked. If required, the toolbars can be reset back to their default 

location by clicking the Reset View button. 

 

Object Locations enables the user to copy the locations/coordinates of objects on the display, to the clipboard. 

 Widgets Menu 
 

The Widgets menu includes the objects pane with all the objects available to build the interface: 

 

The objects –also called widgets–are detailed in the ViSi User Guide. 
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8. ViSi-Genie Specific Menus 
 

ViSi-Genie includes five menus with specific ribbons and options. 

 

ViSi-Genie is codeless and thus completely different from the previous code-based environments, all the menus 

relating to ViSi-Genie are detailed. 

 Home Menu 
 

The Home menu is the main menu… 

 

…with three groups of buttons: 

• File-related commands, 

• Build command, 

• And the objects pane. 

8.1.1. File-Related Buttons 
 

The file-related buttons include the same commands as seen in the File menu: New, Open, Save, Save As and 

Print. 

 

8.1.2. Build Button 
 

The Build button launches the compilation and the upload of the project to the screen. 

 

8.1.3. Objects Pane 
 

The objects pane includes all the objects available to build the interface: 

 

The objects are detailed on the ViSi-Genie User Guide. 
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 View Menu 
 

The View menu includes one important tool for visualising the form: 

 

Click on Snapshot to open a specific window of the form. 

 

This window provides a zoom up to 4 times. The Save button allows to save the screen as an image. 

 Menu Tools 

 

 

All the tools and utilities are grouped here: 

• Click Boot uSD to upload the boot-loader to the screen. 

• Click PmmC Loader to start the PmmC Loader utility. 

• Click ‘Terminal connect 9600’ to open the currently selected com port at 9600 baud in the 

Terminal program. 

• Click ‘Terminal connect 115200’ to open the currently selected com port at 115200 baud in the 

Terminal program. 

• Click Touch Calibration to calibrate the touch on the screen. 

• Click 4DGL uVGA Link to open an interactive window to use mouse/keyboard with the uVGA(GFX) 

module.  

• Click GTX to launch the Genie Test Executor debugger. 
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Clicking the GTX button, a new screen will appear with the form and objects defined in the project: 

 
 

 Comms Menu 
 

This menu is in charge of the communication port: 

 

The use of this menu is described in section 9 “Connect the Module” 

 Project Menu 
 

The Project menu includes different parameters and options… 

 

…with three groups of buttons: 

• Options for Genie, 

• Parameters, 

• And display selection. 
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8.5.1. Genie Options 
 

The first group includes the options for Genie: 

 

 Select the Destination among three possibilities: 

o Run RAM - The display must be connected during Build and the program will be downloaded 

to the display’s flash memory once compiled. The user’s application will be stored in Flash, 

but will be run from RAM. 

o Run Flash - The display must be connected during Build and the program will be downloaded 

to the display’s flash memory once compiled. The user’s application will be stored and run 

from flash, this uses less memory on the display, but makes programs run slightly slower.  

o uSD - The user’s application will be built and copied to the uSD card. From the uSD card the 

application is loaded into RAM and run from there. This option requires the Boot uSD 

program to be uploaded to the display’s flash, as seen in the menu Tools. This Boot uSD 

program loads the user’s application from the uSD card at startup, and executes it. 

 
 

8.5.2. Parameters 
 

The second group include advanced parameters: 

 

 Comms speed Is the baud rate at which the serial command interface operates 

 Define Sound buffer size for the amount of memory set aside for buffering wav (sound) files. For 

simple sound files 1024 bytes should be enough. For complicate sound files to be played whilst video 

is displaying may need as much as 4096 bytes. 
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8.5.3. Display Selection 
 

The last section allows selecting the screen, useful for converting a program from one display module to 

another. Clicking on the button… 

 

…opens a new window to select the screen: 

 

Select the screen from the drop-down list: 

 

Define the orientation among the four options: 

 

Confirm by clicking on   or deny by clicking on . 
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9. Connect the Module 
 

Connect the module to a USB port with the 4D Systems programming cable and select the Comms menu: 

 

Above the Comms section, the violet light mentions no module is currently connected. 

 

Connect the 4D Systems programming cable/adaptor to the module and plug the cable into the USB port. 

Click on the drop-down list and select the COM port relating to the 4D Programming cable/adaptor. 

 

The light turns yellow while the connection is being established: 

 

Finally, the light goes blue when the connection is established. 

 

The light turns red when no module is attached to the selected port: 
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10.  Insert the Micro-SD Card  
 

The Picaso modules, micro-SD card shall be FAT16-formatted. Partition can't exceed 4 GB.  

For Goldelox modules, the micro-SD card shall not be formatted at all, it requires the SD card to be RAW. 

 

To connect the micro-SD card, either 

 Insert the micro-SD card into the USB adaptor and plug the USB adaptor into an USB port of the PC. 

 

Or 

 Insert the micro-SD card into a micro-SD to SD card converter and plug the SD card converter into the 

SD card slot of the PC. 

 

Check the micro-SD card is mounted, here as drive E:. 

 

 
For Goldelox, if prompted to format the SD card, click no/cancel. Leave the card unformatted and Workshop4 
will handle the rest.
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11. Revision History 
 

Revision  Revision Content Revision Date 

1.0 First Release Nov 19, 2012 

1.1 Typos on Page 4 fixed Dec 17, 2012 

1.2 Added new content for Serial and fixed incorrect 
document references 

Feb 4, 2013 

1.3 Amended details about Micro-SD card July 5, 2013  

1.4 Amended details about Program Destination Mar 11, 2014 
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12. Legal Notice 
 
Proprietary Information 
The information contained in this document is the property of 4D Systems Pty. Ltd. and may be the subject of 
patents pending or granted, and must not be copied or disclosed without prior written permission.  
4D Systems endeavours to ensure that the information in this document is correct and fairly stated but does 
not accept liability for any error or omission. The development of 4D Systems products and services is 
continuous and published information may not be up to date. It is important to check the current position with 
4D Systems. 4D Systems reserves the right to modify, update or makes changes to Specifications or written 
material without prior notice at any time. 
All trademarks belong to their respective owners and are recognised and acknowledged. 
 
Disclaimer of Warranties & Limitation of Liability 
4D Systems makes no warranty, either expressed or implied with respect to any product, and specifically 
disclaims all other warranties, including, without limitation, warranties for merchantability, non-infringement 
and fitness for any particular purpose. 
Information contained in this publication regarding device applications and the like is provided only for your 
convenience and may be superseded by updates. It is your responsibility to ensure that your application meets 
with your specifications. 
Images and graphics used throughout this document are for illustrative purposes only. All images and graphics 
used are possible to be displayed on the 4D Systems range of products, however the quality may vary. 
In no event shall 4D Systems be liable to the buyer or to any third party for any indirect, incidental, special, 
consequential, punitive or exemplary damages (including without limitation lost profits, lost savings, or loss of 
business opportunity) arising out of or relating to any product or service provided or to be provided by 4D 
Systems, or the use or inability to use the same, even if 4D Systems has been advised of the possibility of such 
damages. 
4D Systems products are not fault tolerant nor designed, manufactured or intended for use or resale as on line 
control equipment in hazardous environments requiring fail – safe performance, such as in the operation of 
nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life support machines 
or weapons systems in which the failure of the product could lead directly to death, personal injury or severe 
physical or environmental damage (‘High Risk Activities’).     4D Systems and its suppliers specifically disclaim 
any expressed or implied warranty of fitness for High Risk Activities. 
Use of 4D Systems’ products and devices in 'High Risk Activities' and in any other application is entirely at the 
buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless 4D Systems from any and all 
damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, 
under any 4D Systems intellectual property rights. 
 
 
 

13. Contact Information 
 

For Technical Support: support@4dsystems.com.au 

For Sales Support: sales@4dsystems.com.au 

Website: www.4dsystems.com.au 

 

 

 

 

 

 

Copyright 4D Systems Pty. Ltd. 2000-2013. 
 

mailto:Support@4dsystems.com.au
mailto:Sales@4dsystems.com.au
http://www.4dsystems.com.au/


Океан Электроники
Поставка электронных компонентов 

Компания «Океан Электроники» предлагает заключение долгосрочных отношений при 

поставках импортных электронных компонентов на взаимовыгодных условиях! 

Компания «Океан Электроники» является официальным дистрибьютором и эксклюзивным 
представителем в России одного из крупнейших производителей разъемов военного и 
аэрокосмического назначения «JONHON», а так же официальным дистрибьютором и 
эксклюзивным представителем в России производителя высокотехнологичных и надежных 
решений для передачи СВЧ сигналов «FORSTAR». 

Наши преимущества: 

- Поставка оригинальных импортных электронных компонентов напрямую с производств Америки, 
Европы и Азии, а так же с крупнейших складов мира; 
- Широкая линейка поставок активных и пассивных импортных электронных компонентов (более 
30 млн. наименований); 
- Поставка сложных, дефицитных, либо снятых с производства позиций; 
- Оперативные сроки поставки под заказ (от 5 рабочих дней); 
- Экспресс доставка в любую точку России; 
- Помощь Конструкторского Отдела и консультации квалифицированных инженеров; 
- Техническая поддержка проекта, помощь в подборе аналогов, поставка прототипов;  
- Поставка электронных компонентов под контролем ВП; 
- Система менеджмента качества сертифицирована по Международному стандарту ISO 9001; 
- При необходимости вся продукция военного и аэрокосмического назначения проходит 
испытания и сертификацию в лаборатории (по согласованию с заказчиком);
- Поставка специализированных компонентов военного и аэрокосмического уровня качества 
(Xilinx, Altera, Analog Devices, Intersil, Interpoint, Microsemi, Actel, Aeroflex, Peregrine, VPT, Syfer, 
Eurofarad, Texas Instruments, MS Kennedy, Miteq, Cobham, E2V, MA-COM, Hittite, Mini-Circuits, 
General Dynamics  и др.); 

«JONHON» (основан в 1970 г.)

Разъемы специального, военного и аэрокосмического 
назначения: 
(Применяются в военной, авиационной, аэрокосмической, 
морской, железнодорожной, горно- и нефтедобывающей 
отраслях промышленности) 

«FORSTAR» (основан в 1998 г.) 

ВЧ соединители, коаксиальные кабели, 
кабельные сборки и микроволновые компоненты: 

(Применяются в телекоммуникациях гражданского и 
специального назначения, в средствах связи, РЛС, а так же 
военной, авиационной и аэрокосмической отраслях 
промышленности). 

Телефон:    8 (812) 309-75-97 (многоканальный) 
Факс:           8 (812) 320-03-32 
Электронная почта:    ocean@oceanchips.ru 
Web:      http://oceanchips.ru/ 
Адрес:   198099, г. Санкт-Петербург, ул. Калинина, д. 2, корп. 4, лит. А


